Компьютерный форум
Правила
Вернуться   Компьютерный форум > Форум программистов > Програмирование платформенно-независимых систем > Eclipse
Перезагрузить страницу EclipseME установка плагина
Ответ
 
Опции темы Опции просмотра
  (#1 (permalink)) Старый
X-Cite_Forever X-Cite_Forever вне форума
Member
 
Сообщений: 536
Сказал(а) спасибо: 0
Поблагодарили 0 раз(а) в 0 сообщениях
Регистрация: 24.10.2006
По умолчанию EclipseME установка плагина - 11.07.2008, 00:31

EclipseME - плагин позволяющий писать в Eclipse приложения j2me (т.е. на мобильные телефоны)
Трабл в следующем...
Все сделал(подключил, настроил), код пишет, подставляет, проверяет...
Но, не могу запустить, пишет нет процедуры main
Но под мидлеты ее быть то и не должно...
Если я ее вставляю, то соответственно приложение работать на моб телефоне не будет, т.к. не вызывается startApp, но зато тогда компилится проект, можно таким образом проверять на ошибки...
Но все таки, чтобы мне не копировать *.java файлы в папки проектов WTK (или точнее не использовать компиляцию WTK непосредственно, а сделать ее в eclipse)....
Ответить с цитированием
  (#2 (permalink)) Старый
X-Cite_Forever X-Cite_Forever вне форума
Member
 
Сообщений: 536
Сказал(а) спасибо: 0
Поблагодарили 0 раз(а) в 0 сообщениях
Регистрация: 24.10.2006
По умолчанию 11.07.2008, 01:00

Все спасибо.. Нашел как сделать.. Оказывается надо было не Java приложение в настройках Run указывать, а там появилась новая строчка при установке плагина, и надо было ее настраивать...
Теперь как сделать чтобы запускался не один из 4-х эмуляторов, а эмулятор MidpX от Kwyshells, через import добавить не могу, не находит...
Ответить с цитированием
  (#3 (permalink)) Старый
X-Cite_Forever X-Cite_Forever вне форума
Member
 
Сообщений: 536
Сказал(а) спасибо: 0
Поблагодарили 0 раз(а) в 0 сообщениях
Регистрация: 24.10.2006
По умолчанию 11.07.2008, 11:41

И еще... Не могу найти куда ресурсы закидывать... т.е. картинки.. Нашел в инете хелп.. вроде сделал все как там и ничего.. не загружает он картинки... Может кто уже лично делал, тогда описать более подробно...
Ответить с цитированием
  (#4 (permalink)) Старый
X-Cite_Forever X-Cite_Forever вне форума
Member
 
Сообщений: 536
Сказал(а) спасибо: 0
Поблагодарили 0 раз(а) в 0 сообщениях
Регистрация: 24.10.2006
По умолчанию 12.07.2008, 00:04

Ответ нашел.. Оказывается надо еще вручную добавить эти файлы через Add New File и там выбрать существующий файл...
А вопрос еще такой..
Что делает 4-ый параметр в методе Graphics.drawImage(img,x,y,anchors);
Привязка какая-то... При =0 все работает, при других или нет или коряво...
Ответить с цитированием
  (#5 (permalink)) Старый
DjKelt DjKelt вне форума
Новичок
 
Сообщений: 3
Сказал(а) спасибо: 0
Поблагодарили 0 раз(а) в 0 сообщениях
Регистрация: 27.08.2008
По умолчанию 27.08.2008, 17:33

Напиши пожалуйста с какими настройками у тебя работает eclipseme:
- Версия eclipse
- jdk
- eclipseme.core.hooks_*.jar
- писал ли ты такую настройку в конфиге osgi.framework.extensions=eclipseme.core.hooks
- версию wtk
- может еще какие особенности настроек можешь подсказать?

Делаю как в документации и валятся все время ошибки eclipse.

У меня eclipse 3.2.2
eclipseme.feature_1.6.8_site.zip
wtk22
proguard3.9

Все вместе работать не хочет.
Ответить с цитированием
Ads.
  (#6 (permalink)) Старый
X-Cite_Forever X-Cite_Forever вне форума
Member
 
Сообщений: 536
Сказал(а) спасибо: 0
Поблагодарили 0 раз(а) в 0 сообщениях
Регистрация: 24.10.2006
По умолчанию 27.08.2008, 22:18

Значит так...
Я ничего не шарю (базовые принципы) в java и eclipse...
Поэтому никаких надстроек не писал и инструкции по установке не читал.. все делалось методом тыка
Поэтому делал так:
Eclipse тупо принес с работы типа copy/paste.. т.е. не устанавливал даже.. и работает все...
Version: 3.2.2
jdk1.6.0_01
wtk Version 2.3
все. больше ничего не делал...
Теперь сделал так:
В папку plugins закинул все *.jar файлы, только в корень папки plugins, потому что создав папку и закинув туда eclipse не смогла найти...
У меня EclipseMe был в zip архиве вместе с исходниками, а не установочный файл, как везде написано...
Все запускаешь eclipse И вуаля.. он видит...
Теперь чтобы создать проект надо:
File -> New -> Project -> j2me midlet suite
затем там можешь создать package и в нем классы... а можешь не создавать package, а сразу классы, тогда будет пэкэйдж по умолчанию..
Кстати компилировать в jar получается битые файлы.. поэтому итоговую перекомпиляцию в jar я делаю непосредственно через wtk
а проверку, т.е. Run настраиваешь как обыно, но только выбираешь Wireless Toolkit Emulatir...
Вроде доступно...
Как добавлять ресурсы я нашел только один способ который описал ранее... Может кто знает лучше?
Ответить с цитированием
  (#7 (permalink)) Старый
DjKelt DjKelt вне форума
Новичок
 
Сообщений: 3
Сказал(а) спасибо: 0
Поблагодарили 0 раз(а) в 0 сообщениях
Регистрация: 27.08.2008
По умолчанию 28.08.2008, 13:15

Цитата:
Кстати компилировать в jar получается битые файлы.. поэтому итоговую перекомпиляцию в jar я делаю непосредственно через wtk
а проверку, т.е. Run настраиваешь как обыно, но только выбираешь Wireless Toolkit Emulatir...
Cпасибо большое за комментарии. Буду разбираться дальше. Эмулятор у меня работает без проблем в eclipse. Но я попытаюсь все таки сделать нормальный build в eclipse, что бы генерировался исполняемый jar. В одной из своих итераций добился что у меня появилась папка deploy в проекте и там разместились jar файлы, но как я этого добился уже не понимаю. Если добьюсь успехов обязательно здесь напишу. Может кто еще хочет прокомментировать ситуацию и помочь?
Ответить с цитированием
  (#8 (permalink)) Старый
X-Cite_Forever X-Cite_Forever вне форума
Member
 
Сообщений: 536
Сказал(а) спасибо: 0
Поблагодарили 0 раз(а) в 0 сообщениях
Регистрация: 24.10.2006
По умолчанию 28.08.2008, 16:08

вообще компиляция делается так...
Правой кнопкой на проекте в окне слева... в меню выбираешь Create j2me package или что-то в это роде...
И в папке deploy он и создает jar файл... Только у меня на N95 он не запускается... И на эмуляторах тоже... Пишет проблема со стандартным классом...
Ответить с цитированием
  (#9 (permalink)) Старый
DjKelt DjKelt вне форума
Новичок
 
Сообщений: 3
Сказал(а) спасибо: 0
Поблагодарили 0 раз(а) в 0 сообщениях
Регистрация: 27.08.2008
По умолчанию 28.08.2008, 17:24

Я так делаю и у меня создается 3 jar файла один из них работает под моим nokia 6230i без проблем и нареканий.
Ответить с цитированием
Ads
Ответ

Опции темы
Опции просмотра

Ваши права в разделе
Вы не можете создавать новые темы
Вы не можете отвечать в темах
Вы не можете прикреплять вложения
Вы не можете редактировать свои сообщения

BB коды Вкл.
Смайлы Вкл.
[IMG] код Вкл.
HTML код Выкл.
Trackbacks are Вкл.
Pingbacks are Вкл.
Refbacks are Выкл.


Похожие темы
Тема Автор Раздел Ответов Последнее сообщение
Краш плагина flash player'a holy Windows 7 8 02.11.2011 21:46
Ошибка плагина shockwave flash. Emilena Любые вопросы от новичков 1 13.08.2011 20:50
крах плагина adobe flash aleks.tarasow Любые вопросы от новичков 1 06.07.2011 00:06
Парсер на C++ для создания плагина к CRM recovered Вопросы начинающих программистов 1 22.03.2011 14:33
Создание плагина программу для мониторинга температуры и влажности TempControl voldemarius Вопросы начинающих программистов 4 21.02.2011 14:14
установка о.с карен Windows 98/2000 0 01.09.2010 06:58
Начинается установка Windows, но после перезагрузки установка начинается сначала zero000 Накопители 9 21.03.2009 20:22
Insecure dependency in system while running setgid создание плагина fSt Perl 0 11.12.2006 18:32
Регистрация плагина в системе GqRun Trolltech Qt 1 16.11.2006 14:02
Создание плагина для Winamp в SendMessage NicroMan C++ Builder 10 13.02.2006 03:27
Написание плагина Active Phone Server bevice Visual C++ 0 16.07.2003 05:44
Назначение обработчика события главного окна из плагина Anonymous Visual C++ 0 19.06.2003 14:44



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Нardforum.ru - компьютерный форум и программирование, форум программистов